Investigating POS Slowness

Incident Report for Retail Express by Maropost

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 12:28 AEST

Monitoring

POS performance has stabilised. We’ll continue to monitor and validate as traffic increases. Thank you for your patience.

As a precaution, we recommend installing our free Offline POS. It helps ensure uninterrupted service if you experience local internet outages or temporary slowness.

🛠️ https://galaxy.maropost.com/s/article/Installing-Offline-POS
This guide explains how to install and use Offline POS to keep serving customers during connectivity issues.
Posted Apr 16, 2025 - 13:41 AEST

Investigating

We are currently investigating further instances of a performance issue affecting POS responsiveness for a number of users.

If you have Offline POS installed, we recommend switching to Trade Offline mode while we work to identify and resolve the root cause.

For instructions on how to trade offline, please refer to the following article:
🔗 https://galaxy.maropost.com/s/article/Trading-Offline

We appreciate your patience and will provide updates as more information becomes available.
Posted Apr 16, 2025 - 11:42 AEST

Update

We are continuing to monitor for any further issues.
Posted Apr 16, 2025 - 11:34 AEST

Update

We are continuing to monitor for any further issues.
Posted Apr 16, 2025 - 10:05 AEST

Monitoring

POS performance has stabilised. We’ll continue to monitor and validate as traffic increases. Thank you for your patience.

As a precaution, we recommend installing our free Offline POS. It helps ensure uninterrupted service if you experience local internet outages or temporary slowness.

🛠️ https://galaxy.maropost.com/s/article/Installing-Offline-POS
This guide explains how to install and use Offline POS to keep serving customers during connectivity issues.
Posted Apr 15, 2025 - 19:01 AEST

Identified

We’re currently investigating performance issues affecting POS in Maropost Retail Express.

While the root cause is still being determined, our team is working closely with Microsoft to assist with diagnostics and ensure platform stability.

We appreciate your continued patience and understanding.
Posted Apr 15, 2025 - 14:03 AEST

Investigating

We are currently investigating a performance issue affecting POS responsiveness for a number of users.

If you have Offline POS installed, we recommend switching to Trade Offline mode while we work to identify and resolve the root cause.

For instructions on how to trade offline, please refer to the following article:
🔗 https://galaxy.maropost.com/s/article/Trading-Offline

We appreciate your patience and will provide updates as more information becomes available.
Posted Apr 15, 2025 - 12:03 AEST
This incident affected: POS.