Back Office – Degraded Performance on Stock Receipt and Purchase Order Pages

Incident Report for Retail Express by Maropost

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 16:44 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 14, 2025 - 13:49 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 14, 2025 - 13:31 AEST

Investigating

We are currently investigating degraded performance affecting the Back Office Stock Receipt and Purchase Order pages.

Users may experience a blank page, a persistent loading spinner, or be unable to complete a stock receipt. In some cases, the Copy across button does not update Receive qty.

Our engineering team has replicated the issue and is investigating further.
Posted Oct 14, 2025 - 11:40 AEST
This incident affected: Back Office.