Retail Express Back Office access issue – 500 Internal Server Error Incident status

Incident Report for Retail Express by Maropost

Resolved

This issue has now been resolved, and Retail Express services have returned to normal.

If users are still experiencing a blank or white screen after the resolution, please clear your browser cache, history, and session storage, then reload Retail Express. This can help resolve browser-related display issues after service disruption.

Reference: https://galaxy.maropost.com/kb/articles/233-clear-browser-cache-history-and-session-storage

Thank you for your patience while our team worked to resolve this issue.
Posted Jul 03, 2026 - 09:09 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 08:58 AEST

Identified

The issue has been identified, and a potential fix is currently being implemented.
Posted Jul 03, 2026 - 08:25 AEST

Investigating

We are currently investigating an outage affecting the Retail Express platform.

Customers may be unable to access Retail Express Back Office, POS, and API services at this time. Users may see a 500 Internal Server Error or be unable to load their Retail Express site.

Our team is actively investigating the cause and will provide another update as soon as more information is available.
Posted Jul 03, 2026 - 07:35 AEST
This incident affected: POS, Back Office, and API & Integrations.