Retail Express intermittent access and performance issues

Incident Report for Retail Express by Maropost

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 12:48 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 11:54 AEST

Identified

Following the earlier DNS-related outage, Retail Express services have been restored; however, we are continuing to see intermittent access and performance issues for some customers.

Some users may experience slow loading, blank screens, login issues, or intermittent 500 Internal Server Errors when accessing Retail Express Back Office or POS.

Our team has identified additional load on parts of the Back Office platform following service restoration and is performing controlled recovery actions to stabilise access. During this time, some sessions may be interrupted and users may need to refresh or log in again.

If you are still experiencing issues, please try refreshing your browser, clearing your browser cache/session storage, or reconnecting via a different internet source if DNS-related issues persist.

We will provide another update as recovery work progresses.
Posted Jul 03, 2026 - 10:29 AEST
This incident affected: POS, Back Office, and API & Integrations.